Lots of script-driven apps, particularly paid cms, encode their files so as to make sure that they won't be reverse engineered or tampered with. Most of them use an application called ionCube PHP Encoder to do that, so when you acquire a paid script and you want to set it up in a website hosting account, a software instrument known as ionCube Loader needs to be present on the server. Without it, you can't install the script or if you somehow manage to do this, it will not operate efficiently for the reason that almost all of the script code will be encrypted to a point where it can't be interpreted. That's why, you have to ensure that ionCube Loader is set up if you get a fresh web hosting account and you wish to use some paid web app. If you purchase a shared web hosting account and the instrument is not present, it cannot be added because the entire server PHP environment shall have to be compiled again.
IonCube in Hosting
IonCube Loader is a part of all web servers that are a part of our cloud web hosting platform, which means that whatever the hosting service that you choose during the signup process, you can activate it through the Hepsia Control Panel. This process is as easy as clicking an On/Off button inside the Advanced section, so even if this is your first hosting account ever, you won't have to do anything complex. The very same section enables you to select the PHP version for your account (4, 5.2, 5.3, 5.4, 5.5), so in case you would like to switch to another version, you only need to activate ionCube Loader for it as well. As our platform is quite flexible, you can even set a different PHP version and another status of ionCube using a php.ini file in each domain folder. In case this is something you need to do but you don't have much experience, our 24/7 support team shall assist you within minutes.
IonCube in Semi-dedicated Hosting
In case you get a semi-dedicated server plan from us, you will be able to use any kind of script-driven application which requires ionCube Loader because the software tool comes with all servers which are part of our revolutionary cloud web hosting platform. We also support multiple releases of PHP, therefore if you move from PHP 4 to 5.2 or 5.3, for example, you can activate ionCube for this particular release with just a click in your Hepsia Control Panel. Our system will remember your choice, so if you move back to the earlier release of PHP, the instrument will already be active. For more tech-savvy users, we also offer the option to pick the PHP version and if ionCube will be active or not for a specific domain without altering the settings for the whole web hosting account. This is done by putting a php.ini file within a domain folder with a couple of lines of program code.